#1

ReteSW8

Mitglied  (37 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://www.agent-dee.de

Nach Umstellung der Seite von .html auf .php bekomme ich viele 404 Softfehler

Erst einmal ein Hallo an alle Forenmitglieder! smile_16.png

Mittlerweile bin ich am verzweifeln und hoffe hier Hilfe zu bekommen.

Auf meinem Server sind 3 Domains:

1. www.agent-dee.de die Ordner hierzu liegen im Root verzeichnis.

2. www.skylight-tonstudio.de ist serverseitig mit einem Ordner (tonstudio) im Rootverzeichnis verknüpft.

3. s12344565.online.de ist auch serverseitig mit einem Ordner (Webprotest) im Rootverzeichnis verknüpft.

Gebe ich jetzt im Browser die skylight-tonstudio.de ein, sehe ich wie einen Umleitung greift und im Browser www.agent-dee.de/tonstudio ausgegeben wird.

Liegt das an dem redirect in der htaccess?

htaccess
#Umstellung von html auf php
RewriteRule ^(.*).html$ $1.php [R=301,NC]
#Umleitung auf die www.agent-dee.de seite
RewriteCond %{HTTP_HOST} !^(www\.agent-dee\.de)?$ [NC]
RewriteRule (.*) http://www.agent-dee.de/$1 [R=301,L]
 

Die freundlichen Mitarbeiter bei 1&1 meinten ja. Hier würden alle Anfragen auf die agent-dee.de Seite umgeleitet. Oder muss ich die agent-dee.de Seite auch mit einem Unterordner verknüpfen? Mittlerweile habe ich 60 Soft 404 Fehler in den Webmaster Tools und irgendwann stellt der Googlebot seinen Dienst ein.

Um das Ganze einschätzen zu können, was ich falsch mache, fehlt mir einfach das Wissen.

Ich würde mich sehr über eine schnelle Hilfe von Euch freuen.... Mir raucht schon der Kopf. smile_sad_16.png


Gruß und Danke im Voraus

René


Dieser Beitrag wurde bereits 2 mal bearbeitet, zuletzt von »Volker W.« (31.05.2015, 15:10)
#2

Thomas

Co-Admin  (1872 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://siquando-designs.de

Herzlich Willkomen im Forum.

s.12344565-online.de wird sicherlich der Hostname des Servers sein, oder?

Für jede einzelne Domain solltest du innerhalb des Roots-Verzeichnisses einen eigenen Ordner anlegen, da bei bestimmten Konfigurationen die dort hinterlegte .htaccess Datei auch Einfluss auf Unterordner (also Hauptordner anderer Domains) hat. Wenn dein Kopf jetzt schon raucht wird alles Andere früher oder später deinen kopf zum explodieren bringen.

Sehr hilfreich und wissenswert ist sicherlich der Referrer der 404 Meldungen, gute Anleitungen dafür findest du hier oder hier.


Viele Grüße
Thomas

siquando-designs.de (ganz NEU: Santa Cruz Pro für Pro Web 3 und Apollon 10 für Siquando Shop, Tutorials, Templateübersichten & Support für Shop 10 + Pro Web 3)

#3

ReteSW8

Mitglied  (37 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://www.agent-dee.de

Hallo Thomas,

 

ich habe diese Frage auch im Forum Webdesign-BF gestellt und Volker hat mir da schon gantwortet.

Er hat das gleiche wie Du geschrieben.

 

Fehlerseiten habe ich angelegt wie hier im Forum beschrieben.

 

htaccess
RewriteEngine on
 
#Umstellung von html auf php
RewriteRule ^(.*).html$ $1.php [R=301,NC]
 
#Umleitung auf die www.agent-dee.de seite
RewriteCond %{HTTP_HOST} !^(www\.agent-dee\.de)?$ [NC]
RewriteRule (.*) http://www.agent-dee.de/$1 [R=301,L]
 
 
ErrorDocument 401 http://www.agent-dee.de/fehler401.php
ErrorDocument 403 http://www.agent-dee.de/fehler403.php
ErrorDocument 404 http://www.agent-dee.de/fehler404.php

 

Ich habe die Errorseiten mal getestet und Google sagt mir, das der Server kein 404 ausgibt. Funktioniert aber merkwürdigerweise sehr gut.

Nun muss ich aber erst einmal die Siete und die Mobile Seite mit diesem neuen Ordner verknüpfen, im Siquandoprogramm den Ordner als Remote Folder eintragen und die Seite neu uploaden.

Nun habe ich aber eine weiter Frage: was muss ich in der htaccess angeben, wenn ich einen neuen Ordner anlege und die Agent-Dee sowie die Mobile-Seite serverseitig damit verknüpfe, damit Google nicht ins leere rennt?

Da ich die Fragen in 2 Forum gepostet habe werde ich natürlich in beiden die Vorgehensweise / das Ergebniss posten

 

Danke

René

#4

Thomas

Co-Admin  (1872 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://siquando-designs.de

Zitat von: ReteSW8

Ich habe die Errorseiten mal getestet und Google sagt mir, das der Server kein 404 ausgibt. Funktioniert aber merkwürdigerweise sehr gut.

Teilt die Seite auch mit dass es sich um eine Errormeldung handelt?

1
2
3
<?php
 header("HTTP/1.0 404 Not Found");
?>

 

Zitat von: ReteSW8

Nun habe ich aber eine weiter Frage: was muss ich in der htaccess angeben, wenn ich einen neuen Ordner anlege und die Agent-Dee sowie die Mobile-Seite serverseitig damit verknüpfe, damit Google nicht ins leere rennt?

Warum so kompliziert? Du kannst der Domain im Hostingpanel doch sicherlich einen Unterordner als Hauptordner zuordnen, bzw. angeben auf welchen Ordner die Domain zugreifen soll.


Viele Grüße
Thomas

siquando-designs.de (ganz NEU: Santa Cruz Pro für Pro Web 3 und Apollon 10 für Siquando Shop, Tutorials, Templateübersichten & Support für Shop 10 + Pro Web 3)

#5

ReteSW8

Mitglied  (37 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://www.agent-dee.de

Ok. Das geht bestimmt. Habe ich mit den beiden anderen Domains auch so gemacht.

Also dann kein zusätzlicher Eintrag in der htaccess.

Auch ohne Zuordnung des Remote Folders im Siquando-Programm?

In der Fehler404.php habe ich ganz oben ohne Leerzeichen davor folgendes stehen.

 

Fehler404.php
<?PHP
header("HTTP/1.1 404 Not Found");
$filename = 'fehler404.php';
?>

 

Gruß

René  

#6

Thomas

Co-Admin  (1872 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://siquando-designs.de

Bei einer Änderung des „Remote-Folders” ist es natürlich auch ratsam diesen im Programm anzupassen. Mein Tipp:

1. Remote-Folder in SiQ ändern.
2. Seite vollständig hochladen
3. Anpassung des Hauptordners der Domain im Hostingpanel


Viele Grüße
Thomas

siquando-designs.de (ganz NEU: Santa Cruz Pro für Pro Web 3 und Apollon 10 für Siquando Shop, Tutorials, Templateübersichten & Support für Shop 10 + Pro Web 3)

#7

ReteSW8

Mitglied  (37 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://www.agent-dee.de

Eine klitze kleine Frage habe ich noch mal.

Wenn ich die Fehler404.php im Internet Eplorer unter dem Menü (Ansicht - Quelle) anzeigen lasse, muss dan der Code

Fehler404.php
<?PHP
header("HTTP/1.1 404 Not Found");
$filename = 'fehler404.php';
?>

 auch sichtbar sein?

 

Gruß

René

#8

Thomas

Co-Admin  (1872 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://siquando-designs.de

#9

ReteSW8

Mitglied  (37 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://www.agent-dee.de

Na dann ist ja gut. Ich dachte ich hätte schon weider einen Fehler gemacht.

Viele Grüße

René

#10

ReteSW8

Mitglied  (37 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://www.agent-dee.de

Hallo,

ich habe noch mal eine Frage zur Fehlerseite 404 die im Root liegt und von der htaccess angesteuert wird.

Ich habe folgende Schritt durch geführt.

Fehlerseite wie hier beschrieben http://websitebiz.de/marketing-und-mehr/suchmaschinenoptimierung-und-steuerdateien-htaccess-robots-txt/719-suche-link-zur-erstellung-einer-fehlerseite/#post7713 durchgefürt.

Wenn ich jetzt bei Sistrix einen Test durchführe sollte da eigentlich der Code 404, ein Rückgabewert von 200 und ein Redirect von Null stehen. Wenn ich das alles auf der Seite bei Sistrix richtig verstanden habe

Bei mir kommt aber folgendes dabei raus.

Fehler404Test.jpg

 Fehlerseitentest

Was ist den richtig oder was mache ich falsch?

 

Viele Grüße

René

 

#11

ReteSW8

Mitglied  (37 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://www.agent-dee.de

Hallo,

so, nun habe ich die halbe nacht mit der Google-Suche verbracht und bin auf folgendes Ergebnis gekommen wie es laut Sistrix richtig sein soll.

In der 1.Zeile ist der Verweis zur 404error.php mit kompletter Pfadangabe. In diesem Fall bekommt man beim Test auf der Sistrix-Seite die nicht korrekte Rückgabe (Siehe meinen Beitrag #10)

htaccess
1 ErrorDocument 404 http://www.agent-dee.de/404error.php

3 ErrorDocument 404 /404error.php

Lässt man den Pfad zur 404error.php weg, wie in Zeile 3, bekommt man beim anschließenden Test auf der Sistrix-Seite fogendes Ergebnis und so soll es ja richtig sein.

Fehler404Test2.jpg 

 

Gruß

Rene


Dieser Beitrag wurde bereits 2 mal bearbeitet, zuletzt von »ReteSW8« (31.05.2015, 07:51)
#12

Volker W.

Administrator  (6661 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   VolkerWarmers  ·   volkerw68

Die Angabe der Domain à la

ErrorDocument 404 http://www.agent-dee.de/404error.php

ist in Deinem Fall sowieso völlig überflüssig.


Die Domain-Umleitung hast Du mit dem Code

RewriteCond %{HTTP_HOST} !^(www\.agent-dee\.de)?$ [NC]
RewriteRule (.*) http://www.agent-dee.de/$1 [R=301,L]

ja bereits mit drin in Deiner .htaccess.


Somit ist die Syntax

ErrorDocument 404 /404error.php

auch sinnvoller. Die nochmalige Angabe der Domain wäre ja hier doppelt gemoppelt. Je mehr (Umleitungs-)Befehle man der .htaccess mit auf den Weg gibt, desto träger wird die gesamte Performance der Website.


Viele Grüße,
Volker

Volker W. Musik & Sounds  ·  Facebook  ·  Google+  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

Hilfe-Anfragen per PN, E-Mail usw. werden ab sofort nicht mehr beantwortet. Genau dafür ist dieses Forum da. Vielen Dank!

#13

ReteSW8

Mitglied  (37 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://www.agent-dee.de

Ja, im nachhinein macht alles einen Sinn wenn man es so halbwegs verstanden hat.

ABER... man muss sich damit erst einmal auseinandersetzen und die Hilfe die man hier bekommt ist wirklich spitze!!!

Jede angelegte Domain ist jetzt serverseitig mit einem Ordner im Root-Verzeichnis verknüpft wie in Betrag #2 beschrieben. Die Fehlerseite und die htaccess sind jetzt im dem verknüpften Ordner und alle Einträge in den Dateien sind jetzt wir hier beschreiben. Nun hoffe ich, das die Soft 404 Fehler in den Google Webmaster Tools stagnieren.

@Thomas (Frage Beitrag #2): Die s.12344565-online.de ist eine Subdomain die bei jedem Hosting-Paket bei 1&1 gleich mit angelegt ist, damit man gleich mal loslegen kann. Die ist sozusagen als Test-Domain gedacht.

 

Ich fange jetzt folgende Fehler über meine 404error.php ab:

401, 403, 404 und 500 und die 404error.php gibt jetzt immer den Status ´404 Not found´ zurück.

Sollte man für den Fehler ´410 Gone´ eine eigene Fehlerseite erstellen, damit der richtige Antwortcode zurückgegeben wird oder reicht es wenn ich den Fehler 410 auch mit der 404error.php abfange?

 

Noch eine Frage hinterher. Bei dem Google Speed Tool verhindert einen Scipt-Datei jq.js (Siquando Web 😎 das Rendern der Smartphone-Seite. Gibt es dafür eine Lösung? Wenn ja, sollte ich dafür besser ein neues Thema beginnen?

Danke und Gruß

René

#14

Volker W.

Administrator  (6661 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   VolkerWarmers  ·   volkerw68

Zitat von: ReteSW8

Sollte man für den Fehler ´410 Gone´ eine eigene Fehlerseite erstellen, damit der richtige Antwortcode zurückgegeben wird oder reicht es wenn ich den Fehler 410 auch mit der 404error.php abfange?

Du solltest theoretisch für jeden von Dir genannten Fehler eine eigene Fehlerseite anlegen. 401, 403, 500 usw. sind ja alle nicht gleich 404. ;-)

Zitat von: ReteSW8

Noch eine Frage hinterher. Bei dem Google Speed Tool verhindert einen Scipt-Datei jq.js (Siquando Web 😎 das Rendern der Smartphone-Seite. Gibt es dafür eine Lösung? Wenn ja, sollte ich dafür besser ein neues Thema beginnen?

JA bitte! Obwohl ich dies (wenn ich es jetzt korrekt verstanden habe) nicht als einen Fehler von Siquando Web 8 ansehe. Falls Du dies diskutieren möchtest, poste dies jedoch bitte trotzdem separat in einem neuen Thema.


Viele Grüße,
Volker

Volker W. Musik & Sounds  ·  Facebook  ·  Google+  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

Hilfe-Anfragen per PN, E-Mail usw. werden ab sofort nicht mehr beantwortet. Genau dafür ist dieses Forum da. Vielen Dank!

#15

ReteSW8

Mitglied  (37 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://www.agent-dee.de

Ich sehe das auch nicht als Fehler von Siquando Web, aber es ist ein Ranking-Faktor.

Ich werde die Frage gleich mal zum Diskutieren posten.

 

Gruß

René

1472 Aufrufe | 15 Beiträge