#1

ReteSW8

Mitglied  (37 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://www.agent-dee.de

Links zeigen auf den alten mobiler Ordner mobile/smartphone

Hallo liebe Forenmitglieder,

ich war lange nicht mehr hier, habe aber trotzdem immer mal wieder online, 1-2 mal die Woche, geschaut was sich hier so tut. Also immer passiv dabei. Ja warum bin ich heute mal wieder aktiv dabei? Weil ich Hilfe brauche und mal ganz lieb frage ob mir einer helfen kann.


Kurzer Abriss…was habe ich gemacht:

Habe meine Homepage auf responsive (Siquando Web 9 Design Riga) umgestellt.


D.h.:

Mobile Subdomain (m.meinedomain.de) nicht gelöscht (den Inhalt schon) und im Rootverzeichnis eine .htaccess mit einem Redirect 301 / http://meine-hompage.de der auf die responsive Seite zeigt eigerichtet. Das funktioniert auch alles bestens und unter Google verschwinden die Links nach und nach. Die mobile Subdomain war serverseitig mit dem Ordner „smartphone“ verknüpft.

Die Hauptdomain habe ich ein bisschen aufgeräumt (es war einfach to much), einfacher strukturiert und Verzeichnisse umbenannt. Hierfür habe ich auch in der .htaccess Redirects 301 /altername http://neuername/info.php und eigene Fehlerseiten (401, 402, 404 usw.) eingerichtet.


Nun komme ich zum Problem.

In den Webmaster Tools bekomme ich ein Redirect-Fehler angezeigt und zwar mit folgenden Link-Inhalt. www.Hauptdomain.de/mobile/smartphone/datei mobile/smartphone kommt doch aus dem alten Design oder?

Ich habe im neuen Responsiv-Design natürlich kein Smartphone-Design ausgesucht und auch in den erweiterten Eigenschaften kein Haken beim Pfad mobile/etc. gesetzt. Wäre ja auch ein fataler Fehler. 

Wenn ich den Link www.meinedomain.de/mobile/smartphone/datei im Internet Explorer eingebe, gibt es eine Fehlermeldung „to many choices“. also ein Redirect Loop. 

Wie bekomme ich das mit einem Redirect in der .htaccess in den Griff? Ich habe schon vieles probiert wie z.B.

Redirect 301 mobile/smartphone http://meine-hompage.de/info.php. Hat aber nix geholfen.

Es wäre echt lieb und vielen lieben Dank im Voraus, wenn mir einer von Euch helfen könnte. Ich kenne mich bei den Regeln für Redirects und wie man sie genau einsetzt, um so etwas in den Griff zu bekommen, einfach nicht gut genug aus.


Also, vielen lieben Dank im Voraus

René


Dieser Beitrag wurde bereits 1 mal bearbeitet, zuletzt von »Volker W.« (19.02.2018, 20:18)
#2

Thomas

Co-Admin  (1872 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://siquando-designs.de

#3

ReteSW8

Mitglied  (37 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://www.agent-dee.de

#4

Volker W.

Administrator  (6657 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   VolkerWarmers  ·   volkerw68

Ich würde einfach zwischen der www-Umleitung und den Seitenumleitungen folgendes einfügen:

#Umleitung /mobile/smartphone/ auf Hauptverzeichnis
RewriteRule ^/?mobile/smartphone/?(.*)$ /$1 [R=301,L]


Viel Erfolg! 😉


Viele Grüße,
Volker

Volker W. Musik & Sounds  ·  Facebook  ·  Google+  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

Hilfe-Anfragen per PN, E-Mail usw. werden ab sofort nicht mehr beantwortet. Genau dafür ist dieses Forum da. Vielen Dank!

#5

ReteSW8

Mitglied  (37 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://www.agent-dee.de

Hallo Volker,

habe ich gemacht. hm... geht nicht.

Nun habe ich den Link aus den Webmaster Tools mal direkt mit dem Internetexplorer-Befehl "Link in neuer Seite öffnen" geöffnet und nun erscheint der Link etaws anders.

Erst einmal die Fehlermeldung aus den Webmaster Tool als Screen-Shot und im Exploerer göffnet sieht es so aus. Da steht

Webmaster%20Tools-640px.jpg

Zeigt komischerweise auf sich selbst 😞

http://www.meinhomepage.de/index.phpmobile/smartphone/bandmitglieder/michaela-vocals-backings-and-percussion.php (Habe vorn den Domainnamen in meinehomepage geändert) hinter meinehomepage.de kommt es mir etwas merkwürdig vor index.phpmobile das ist echt komisch.

Liegt das vielleicht an der htaccess -Umleitung von der alten molbilen-Subdomain?

In dieser steht nur und folgendes

Redirect 301 / http://www.agent-dee.de/index.php 

Wird hier vielleicht das index.php mitgegeben und deshalb geht das nicht?

 

Danke und viele Grüße

René


Dieser Beitrag wurde bereits 1 mal bearbeitet, zuletzt von »ReteSW8« (17.02.2018, 07:29)
#6

ReteSW8

Mitglied  (37 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://www.agent-dee.de

Hallo Volker,

so jetzt geht es immer mehr und mehr. Noch mal ganz lieben Dank für die tolle Unterstützung hier. Ich bekomme auch total andere Ergebnisse wenn ich den Link im Explorer oder in Chrome teste. Das muss am Cache liegen und am CDN das ich benutze. 1 Tag gewartet und schon siehet es besser aus.

Ich habe mal die Ergebnisse von einem Status Code Checker als Bilder eingefügt.

Status%20Code%20Checker.jpg

Und Links die ich noch nicht in der htaccess abgefangen habe landen zumindest schon mal auf unserer Fehler 404 Seite.

Status%20Code%20404.jpg

Jetzt habe ich noch mal eine Frage zum Redirect Code. Wenn ich ein Verzeichnis auf ein anderes, mit Redirect 301, umleiten will, wie ist da der genaue Code? Mit oder ohne Schrägstrich / am Ende.Im Internet stehen so viele unterschiedliche Varianten.

Redirect 301 /altes_verzeichnis http://meine_domain/neues_verzeichnis oder

Redirect 301 /altes_verzeichnis/ http://meine_domain/neues_verzeichnis/

Nochmals vielen Dank und einen schönen Tag

René

#7

Volker W.

Administrator  (6657 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   VolkerWarmers  ·   volkerw68

Ich hätte den Code in Beitrag #4 nicht gepostet, wenn er nicht funktionieren würde. 😉

Wichtig ist, daß er mit RewriteEngine On eingeleitet wird, also z.B. so:

RewriteEngine On
RewriteBase /

RewriteRule ^/?mobile/smartphone/?(.*)$ /$1 [R=301,L]


Aber das war bei Dir ja schon so, wenn Du den Code wie empfohlen einfach an der entsprechenden Stelle hinzugefügt hast.


Alternativ kannst Du auch so umleiten:

Redirect 301 /mobile/smartphone http://www.agent-dee.de


Ich würde es ohne den abschließenden Slash machen. Alles was danach folgt (inklusive des Slashes), wird der Ziel-URL sowieso angehangen.


Viele Grüße,
Volker

Volker W. Musik & Sounds  ·  Facebook  ·  Google+  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

Hilfe-Anfragen per PN, E-Mail usw. werden ab sofort nicht mehr beantwortet. Genau dafür ist dieses Forum da. Vielen Dank!

#8

ReteSW8

Mitglied  (37 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://www.agent-dee.de

Hallo Volker,

vielen Dank.

Ich meint das aber etwas anders und nicht mehr auf die Umleitung auf die Hauptdomian bezogen. Siehe Beitrag #6 von mir, dort landet der alte Link Bandmitglieder noch auf die error404.php und den möchte ich um-rooten per 301 auf die neue Adresse "Band"

Redirect 301 /bandmitglieder http://www.agent-dee.de/band
oder
Redirect 301 /bandmitglieder/ http://www.agent-dee.de/band/

Gilt hier auch besser ohne / und wird bei der Zeil-Url angehängt?

Gruß

Rene

#9

Thomas

Co-Admin  (1872 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://siquando-designs.de

Üblicherweise wird bei Ordnern ein Slash angehangen, wie auch auf deiner Seite. Deshalb würde ich auch die Variante mit dem Slash verwenden.


Viele Grüße
Thomas

siquando-designs.de (ganz NEU: Santa Cruz Pro für Pro Web 3 und Apollon 10 für Siquando Shop, Tutorials, Templateübersichten & Support für Shop 10 + Pro Web 3)


Dieser Beitrag wurde bereits 1 mal bearbeitet, zuletzt von »Thomas« (19.02.2018, 10:03)
#10

ReteSW8

Mitglied  (37 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://www.agent-dee.de

Hallo Thomas,

dankeschön. 🙂

Ich habe es jetzt in der .htaccess mit Slash am Ende eingeben und je nach dem wie man es in der Browser-Url-Zeile eingibt bekommt andere Ergebnisse.

Gibt man die URL mit Slash ein kommt man auf die richtige 301 Umleitung mit dem Ergebniss 200 OK und ohne auf die landet man auf der 404-Fehlerseite.

Mit%20und%20ohne%20schraegstrich.jpg

Nochmals vielen Dank. 🙂

René

#11

Volker W.

Administrator  (6657 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   VolkerWarmers  ·   volkerw68

Ich würde die Variante ohne Slash am Ende wählen, denn diese deckt die Variante mit Slash am Ende gleichzeitig mit ab. Alles nachfolgende - also auch der Slash - wird ja sowieso mit in die Ziel-URL übernommen.


Viele Grüße,
Volker

Volker W. Musik & Sounds  ·  Facebook  ·  Google+  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

Hilfe-Anfragen per PN, E-Mail usw. werden ab sofort nicht mehr beantwortet. Genau dafür ist dieses Forum da. Vielen Dank!

284 Aufrufe | 11 Beiträge