#1

sportpixel

Mitglied  (26 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://www.sportpixel.com

Fehlermeldung 417 nach Abschluss des Uploads

Ich habe nun versucht mein erstes NG Projekt (Demo) mit dem NG Project Central zu installieren bzw. aktualisieren. Es werden 93 Pakete entpackt und auf den Server geladen. Die letzte Datei ist der NGCLIENT.exe soweit ich das mitbekommen habe. 

Dan erhalte ich die Fehlermeldung 417 nach Abschluss des Uploads:"Netzwerkfehler - 417 Expectation Failed".

Eine Vorschau auf die Seite oder Zugriff erhalte ich nicht, da der upload nicht abgeschlossen wurde.

Woran liegt das? Ich habe es nun 4mal probiert (Vollständiger Upload oder auch nur Aktualisierung), doch ich erhalte immer diese Fehlermeldung.


Dieser Beitrag wurde bereits 1 mal bearbeitet, zuletzt von »Volker W.« (22.03.2014, 13:28)
#2

Volker W.

Administrator  (6661 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   VolkerWarmers  ·   volkerw68

Ich vermute, daß bei Dir die WWW-Adresse und der Basis-Ordner nicht synchron sind, sprich Deine Domain muß beim Provider in genau diesen Ordner geroutet werden.

Führt denn in Project Central im Bereich "Webserver" der Klick auf den Button "Prüfen und Weiter zum nächsten Schritt" zum Erfolg?


Viele Grüße,
Volker

Volker W. Musik & Sounds  ·  Facebook  ·  Google+  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

Hilfe-Anfragen per PN, E-Mail usw. werden ab sofort nicht mehr beantwortet. Genau dafür ist dieses Forum da. Vielen Dank!

#3

sportpixel

Mitglied  (26 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://www.sportpixel.com

Bei der Überprüfung klappt alles einwandfrei.

Irgendwie scheint etwas mit der Clientdatei nicht zu funktionieren, denn auch bei  "In web 2 date bearbeiten" und der darauf folgenden Anmeldung erhalte ich den Fehler.

Kann es sein, dass die Datei zu groß für den Upload auf den Server ist? Das Problem existierte ja bereits bei den herkoemmlichen web2date Versionen, dass man oftmals gezwungen wurde die Dateien nicht mit dem Uploadclienten hoch zu laden sondern mit dem eigenem FTP Programm. Warum dieser Fehler sich durch alle Versionen bis hin zu 8s gezogen hat und nun wahrscheinlich auch in NG ist, kann ich allerdings nicht nach vollziehen.

Aber geht das bei NG auch? (Vorausgesetzt daran liegt es).

#4

Volker W.

Administrator  (6661 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   VolkerWarmers  ·   volkerw68

Der von Dir beschriebene Vergleich zwischen web to date Classic und web to date NG bzgl. der Upload-Abbrüche trifft so nicht zu. Die beiden Phänomene haben rein gar nichts miteinander zu tun.

Die ngclient.exe von NG ist ca. 17 MB groß. Von daher ist es erforderlich, daß der Webserver Dateien dieser Größe beim Upload auch akzeptiert.

Schaue mal per info.php in Deine PHP-Einstellungen und prüfe, ob bei upload_max_filesize ein genügend großer Wert steht. Falls nicht, muß der Wert entsprechend erhöht werden. Das kann i.d.R. der Provider vornehmen.

Möglichkeit B wäre, die ngclient.exe beim Upload wegzulassen. Dazu müßtest Du aus dem Programmverzeichnis von web to date NG aus dem Unterverzeichnis \Plugins die Datei NGWindowsClient.ngpackage entfernen und den Upload danach nochmal wiederholen.


Viele Grüße,
Volker

Volker W. Musik & Sounds  ·  Facebook  ·  Google+  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

Hilfe-Anfragen per PN, E-Mail usw. werden ab sofort nicht mehr beantwortet. Genau dafür ist dieses Forum da. Vielen Dank!

#5

sportpixel

Mitglied  (26 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://www.sportpixel.com

Die maximale Dateigroeße beträgt, gemäß PHP Info, 20MB und sollte damit für die Datei ausreichend sein, oder?

Ich bin mir auch nicht sicher, ob es wirklich an dieser Datei liegt. Unter Seitenvorschau wird mir gar nichts angezeigt.

Die Fehlermeldung kommt nur ganz zum Schluß also bei oder nach dem upload der Datei...das kann ich leider nicht feststellen.

#6

Volker W.

Administrator  (6661 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   VolkerWarmers  ·   volkerw68

20 MB sind jetzt nicht die Welt, sollten jedoch soweit erstmal reichen.

Hast Du denn mal geprüft, ob WWW-Adresse und Basis-Ordner wirklich synchron sind? Lade dazu einfach mal eine test.html Datei mit dem simplen Inhalt "Dies ist ein Test!!!" per FTP-Programm in den Basis-Ordner und prüfe anschließend, ob Du im Browser mit Aufruf der URL http://www.deine-domain.xy/test.html (also quasi <WWW-Adresse>/test.html) auch auf genau diese Datei stößt.

Den Erfolg bzw. Mißerfolg teilst Du uns hier danach nochmal mit.


Viele Grüße,
Volker

Volker W. Musik & Sounds  ·  Facebook  ·  Google+  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

Hilfe-Anfragen per PN, E-Mail usw. werden ab sofort nicht mehr beantwortet. Genau dafür ist dieses Forum da. Vielen Dank!

#7

sportpixel

Mitglied  (26 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://www.sportpixel.com

Das habe ich ja schon mit der info.php Datei gemacht, um herauszufinden, wie groß die maximale Dateigroeße sein darf.

Das funktioniert also und auch die Überprüfung mit dem NG Client funktioniert anstandslos.

#8

Volker W.

Administrator  (6661 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   VolkerWarmers  ·   volkerw68

Wenn Du das mit der info.php bereits gemacht hast, dann kannst Du ja auch direkt mal prüfen, ob der von Dir verwendete Webserver auch die Systemvoraussetzungen von web to date NG in ausnahmslos allen Punkten erfüllt.

Poste auch gerne mal den Link zu Deiner info.php.


Viele Grüße,
Volker

Volker W. Musik & Sounds  ·  Facebook  ·  Google+  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

Hilfe-Anfragen per PN, E-Mail usw. werden ab sofort nicht mehr beantwortet. Genau dafür ist dieses Forum da. Vielen Dank!

#9

sportpixel

Mitglied  (26 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://www.sportpixel.com

Auf was muss ich da besonders achten?

Die alten Versionen liefen bzw. laufen jedenfalls :)
Beweis findest du hier....http://www.sportpixel.com...die Seite wurde mit der Version 8s erstellt.

Die Info PHP befindet sich in dem Testpfad den ich für NG angelegt habe und wo eigentlich jetzt die Demoseite zu sehen sein sollte....

http://sport.sportpixel.com/info.php

#10

Volker W.

Administrator  (6661 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   VolkerWarmers  ·   volkerw68

Die Systemvoraussetzungen von Classic (8s und älter) und NG unterscheiden sich auch erheblich.

Ich habe mir Deine info.php angesehen. Offensichtlich unterstützt Dein Server kein mod_rewrite. Dies ist jedoch eine zwingende Voraussetzung für NG.

Die Systemvoraussetzungen waren im DATA BECKER Online-Shop stets bei jedem Produkt prominent auf der Kaufseite ersichtlich. U.a. hier kannst Du sie noch nachsehen.


Viele Grüße,
Volker

Volker W. Musik & Sounds  ·  Facebook  ·  Google+  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

Hilfe-Anfragen per PN, E-Mail usw. werden ab sofort nicht mehr beantwortet. Genau dafür ist dieses Forum da. Vielen Dank!

#11

sportpixel

Mitglied  (26 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://www.sportpixel.com

Ich habe mir die Systemvoraussetzungen noch nie durchgelesen, da diese für mich nicht verständlich sind und bisher hat auch immer alles geklappt.

Als Fotograf arbeite ich normalerweise mit einem Mac und dieses Programm erfordert Windows, dass verstehe ich noch (zumindest theorethisch). Was es aber bedeutet das ein "mod_rewrite aktiviert" sein soll verstehe ich wieder nicht.

Wo kann man das denn aktivieren? Muss ich da den Serverbetreiber anschreiben?
Ich finde den Eintrag nicht einmal in der Info Datei.


Dieser Beitrag wurde bereits 1 mal bearbeitet, zuletzt von »sportpixel« (16.03.2014, 22:02)
#12

Volker W.

Administrator  (6661 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   VolkerWarmers  ·   volkerw68

Also wenn Du nicht gerade einen eigenen Server betreibst, den Du in allen Belangen selbst administrierst, sondern ein normales Paket bei einem der vielen Webhosting-Provider, so kannst Du dies normalerweise nicht selbst einstellen.

Wende Dich dazu also bitte an Deinen Provider und bitte entweder um Aktivierung von mod_rewrite oder um einen Wechsel in ein diesbezüglich unterstützendes Paket. Beachte bitte auch alle anderen Punkte der Systemvoraussetzungen des Webservers. Ich habe zwar ansonsten keinen weiteren Konflikt mehr in Deiner info.php gefunden, aber das muß in Deinem zukünftigen Paket dann natürlich ebenfalls wieder so sein (+ mod_rewrite).


Viele Grüße,
Volker

Volker W. Musik & Sounds  ·  Facebook  ·  Google+  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

Hilfe-Anfragen per PN, E-Mail usw. werden ab sofort nicht mehr beantwortet. Genau dafür ist dieses Forum da. Vielen Dank!

#13

Volker W.

Administrator  (6661 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   VolkerWarmers  ·   volkerw68

Nachtrag:

mod_rewrite ist eine technische Eigenschaft des Webservers, per entsprechenden Befehlen in der .htaccess Datei URLs "umbiegen" zu können. Dies wird mit einem entsprechenden Modul im Zusammenspiel mit der Apache-Software auf Deinem Server realisiert.


Viele Grüße,
Volker

Volker W. Musik & Sounds  ·  Facebook  ·  Google+  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

Hilfe-Anfragen per PN, E-Mail usw. werden ab sofort nicht mehr beantwortet. Genau dafür ist dieses Forum da. Vielen Dank!

#14

sportpixel

Mitglied  (26 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://www.sportpixel.com

Zum Glück kann man das bei meinem Provider anscheinend selbst alles anpassen....

 

"PHP Mod Rewrite anpassen

Bei der RB Media Group, hat jeder Kunde seine eigene PHP.ini zur Verfügung, daher kann die Mod Rewrite Unterstützung wahlweise aktiviert oder deaktiviert werden. 

Standard:  On 
Für jede Domain können Sie im Confixx unter Einstellungen -> httpd Spezial Ihre PHP Einstellungen anpassen. 
Bitte beachten Sie das der Server ca. 3-5 Minuten für die Übernahme der Einstellungen benötigt. 
Um Mod_rewrite nutzen zu können, muss in der ersten Zeile Ihre .htaccess Datei folgendes stehen: 
Options +FollowSymlinks "

Bei mir war es deaktiviert und ich habe jetzt auf "On" geschaltet...mal sehen ob es nun klappt.
Ob es nun wirklich eingeschaltet ist weiß ich nicht, da ich den Eintrag in der PHP.info - Datei immer noch nicht gefunden habe.

Ich habe danach gleich mal versucht auf "installieren und aktualisieren" zu klicken und abgewartet was passiert...und wieder: Es werden die Dateipakete hoch geladen und am Schluß erhalte ich die altbekannte Fehlermeldung. :(


Dieser Beitrag wurde bereits 1 mal bearbeitet, zuletzt von »sportpixel« (16.03.2014, 23:09)
#15

Volker W.

Administrator  (6661 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   VolkerWarmers  ·   volkerw68

Vermutlich hast Du mit dem Upload Deine modifizierte .htaccess mit der originalen aus NG überschrieben.

Wenn Du möchtest, gib mir mal per PN Deine FTP-Daten durch. Dann sehe ich mir das einmal an. Insofern Dein Webserver wirklich alle serverseitigen Systemvoraussetzungen erfüllt, bekommen wir NG definitiv auch ans Laufen!!!

Ggf. benötige ich ebenfalls Zugang zu Deinem Provider-Backend. Das würde ich dann aber separat nur bei Bedarf nochmal von Dir anfordern.


Viele Grüße,
Volker

Volker W. Musik & Sounds  ·  Facebook  ·  Google+  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

Hilfe-Anfragen per PN, E-Mail usw. werden ab sofort nicht mehr beantwortet. Genau dafür ist dieses Forum da. Vielen Dank!

#16

Volker W.

Administrator  (6661 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   VolkerWarmers  ·   volkerw68

Zur Info für alle:

Die Angelegenheit wurde heute erfolgreich gelöst. sportpixel hat mir per PN seine Zugangsdaten inkl. Admin-Backend Provider zukommen lassen. Nachdem ich im Backend des Webservers das PHP Memory Limit auf 256 MB eingestellt habe und nochmals sichergestellt habe, daß a) der Wert für PHP upload file size auf 20 MB eingestellt und b) mod_rewrite aktiviert ist (beides hatte sportpixel im Vorfeld bereits selbst auf mein Anraten hin angepaßt), konnte das NG-Projekt ohne jegliches Problem veröffentlicht werden.

Alle Probleme behoben!!!


Nachfolgend nochmals alle Voraussetzungen Punkt für Punkt:


Systemvoraussetzungen Server

  • Apache Webserver mit FTP-Zugang und mind. 2 GB freiem Speicherplatz
  • PHP 5.3 (empfohlen PHP 5.4)
  • MySQL 5 Datenbank
  • GD-Lib ab Version 2.0
  • memory_limit 96 MB (empfohlen 128 MB oder höher)
  • Erstellung und Modifikation von .htaccess Dateien
  • mod_rewrite aktiviert
  • allow_url_fopen aktiviert
  • cURL aktiviert
  • magic_quotes deaktiviert
  • register_globals deaktiviert


Systemvoraussetzungen Client

  • Windows-kompatibler PC mit Windows XP (SP3) oder Vista (SP2), empfohlen mit Windows 7 (SP1) oder Windows 8
  • Bildschirmauflösung mit 1280 x 800 Pixeln (empfohlen 1680 x 1050 oder höher)
  • Internet Explorer 10 (empfohlen)
  • Internetzugang mit mind. 6 MBit/s (empfohlen 16 MBit/s oder besser)


Resümee:

Wenn die Systemvoraussetzungen von web to date NG vom Webserver in ausnahmslos allen Punkten erfüllt werden, kommt es auch zu keinerlei Problemen.


Viele Grüße,
Volker

Volker W. Musik & Sounds  ·  Facebook  ·  Google+  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

Hilfe-Anfragen per PN, E-Mail usw. werden ab sofort nicht mehr beantwortet. Genau dafür ist dieses Forum da. Vielen Dank!

#17

sportpixel

Mitglied  (26 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://www.sportpixel.com

Vielen, vielen Dank Volker!

Selbst wenn die Plattform die Voraussetzungen erfüllt oder man verschiedene Dinge selbst anpassen kann, muss man doch vorerst wissen wo man danach suchen muss. Mir ist es als "Anwender" jedenfalls nicht leicht gefallen und bin froh, dass du mir geholfen hast!

 

3346 Aufrufe | 17 Beiträge