#1

Saltimbanco

Mitglied  (29 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://www.extravaganzas.de

Hallo zusammen,

ich bin mir nicht sicher, ob diese Frage schon einmal in diesem Forum behandelt wurde. Ich habe nun die neueste Version Siquando Shop 10 käuflich erworben und habe diese mit meinen Daten "gefüttert". Das Verarbeiten der Daten hat soweit funktioniert. Ein Ansehen der Website auf meinem Laptop hat auch funktioniert. Jedoch nach dem Hochladen auf den Webspace meines Providers (1&1) erhielt ich die Nachricht:

Warning: mysqli_connect(): (HY000/1045): Access denied for user 'dbo754005706'@'212.227.127.58' (using password: YES) in /homepages/30/d152258316/htdocs/shop/assets/s2dimysql.php on line 34

Die Datenbankverbindung ist fehlgeschlagen, bitte überprüfen Sie die Datenbank-Einstellungen


Mir ist diese Fehlermeldung nicht klar, zumal ich mehrmals die Daten meiner MySQL-Datenbank richtig und vollständig in das dafür vorgesehene Feld von Shop 10 eingetragen habe. Nach Durchsicht meiner Datenbank habe ich festgestellt, daß keinerlei Daten in diese Datenbank geschrieben worden sind, was ich nicht verstehen kann. Die Zugangsdaten habe ich richtig und vollständig eingegeben.

Gibt es im Forum User bzw. Userinnen, die dieses Problem ebenfalls haben oder hatten? Und welche möglichen Lösungsansätze kann ich unternehmen, um diese o.g. Problemstellung gelöst zu bekommen?


Vielen Dank für Euren Input!

Saltimbanco


Dieser Beitrag wurde bereits 1 mal bearbeitet, zuletzt von »Volker W.« (21.09.2018, 20:52)
#2

Thomas

Co-Admin  (1872 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://siquando-designs.de

Die Fehlermeldung lässt vermuten, dass die Zugangsdaten nicht korrekt eingetragen wurden.


Viele Grüße
Thomas

siquando-designs.de (ganz NEU: Santa Cruz Pro für Pro Web 3 und Apollon 10 für Siquando Shop, Tutorials, Templateübersichten & Support für Shop 10 + Pro Web 3)

#3

Saltimbanco

Mitglied  (29 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://www.extravaganzas.de

Hallo Thomas,

 

vielen dank für Deine Nachricht.

Es ist richtig, daß ich zunächst die Zugangsdaten der SQL-Quelle genau analysiert habe, jedoch ist mir bei der Eingabe kein Fehler - z.B. Schreibfehler - unterlaufen. Ich habe deshalb auch mit der o.g. Fehlermeldung meine großen Probleme, da es nicht an den Eingaben meinerseits liegen mag.

 

In diesem Zusammenhang ist mir bei der Fehlermeldung folgende Notation aufgefallen "mysqli ..." mit dem Zusatz "i, jedoch kann ich als SQL-Laie nicht soviel anfangen. Nach meinen Recherchen soll das sqli eine verbesserte Form von SQL sein (!?!). Jedoch weiß ich nicht, wie ich diese Fehlermeldung nun lösen kann.

 

Gruss

 

Saltimbanco

 

#4

Volker W.

Administrator  (6661 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   VolkerWarmers  ·   volkerw68

Die Meldung "Access denied for user ..." ist ziemlich eindeutig. Die Zugangsdaten stimmen nicht 100% mit den beim Provider für die Datenbank hinterlegten überein.

Bzgl. mysqli solltest Du eine möglichst neue PHP-Version verwenden, optimalerweise PHP 7.2.


Viele Grüße,
Volker

Volker W. Musik & Sounds  ·  Facebook  ·  Google+  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

Hilfe-Anfragen per PN, E-Mail usw. werden ab sofort nicht mehr beantwortet. Genau dafür ist dieses Forum da. Vielen Dank!

#5

Saltimbanco

Mitglied  (29 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://www.extravaganzas.de

Hallo Volker,

 

ich werde nochmals Deine Infos abgleichen und mich dann wieder melden ... Danke vorab

 

Gruss Saltimbanco

 

#6

Saltimbanco

Mitglied  (29 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://www.extravaganzas.de

Hallo Volker,

 

das Problem ist gelöst - Ich habe nochmals eine SQL-Datenbank über das System bei 1&1 neu initiieren lassen. Habe alle Daten eingefügt und jetzt hat es ordnungsgemäß funktioniert.

 

Mir ist das ein absolut Rätsel, wieso dies vorher mit den alten SQL-Daten nicht funktionierte obwohl ich alle Daten richtig eingegeben hatte. Nun ja, jetzt funktioniert alles und dieser Beitrag kann als "erfolgreich geschlossen" werden.

 

Danke nochmals für Deine Hilfe

 

LG

Saltimbanco

 

453 Aufrufe | 6 Beiträge