#1

Bibserich

Forum-Sponsorin  (27 Punkte)  ·   weiblich  ·   Deutschland  ·    Nachricht senden
 https://www.philharmonischerchor-friedrichshafen.de

Hallo zusammen,

da ich hier schon wertvolle Hilfe erhalten habe, hier nun mein nächstes Problem mit der Hoffnung auf Lösung. 

Ich habe nun meine nächste Website auf Plural umgestellt. Alles ist chic und gut, allerdings lädt die Startseite nicht richtig hoch und ich verzweifle langsam. Habe es auf allen verschiedenen Medien probiert und verschiedenen Browsern, es geht nicht. Sämtliche Verläufe und Cache habe ich geleert. Es zeigt die ursprüngliche Startseite an, aber ohne Struktur. Klicke ich auf eine nächste Hauptseite ist alles da und ich komme auch so wieder auf die richtige Startseite. Ebenso ist die Homepage einmal SSL-verschlüsselt und dann wieder nicht.

Das ist die Website: www.bodensee-idylle.de

So sieht diese 😞 Startseite aus.

Liegt's am Provider? Was kann ich tun?

Grüße, Andrea



Dieser Beitrag wurde bereits 4 mal bearbeitet, zuletzt von »Volker W.« (18.08.2018, 23:43)
#2

W2D Fan

Co-Admin  (3012 Punkte)  ·   weiblich  ·   Niederlande  ·    Nachricht senden
 http://www.w2dfan.nl

 Seit schon immer muß man bei einer Versionswechsel UND bei einem Designwechsel  ZWINGEND das erste Mal die Seite erstellen mit der Erstellungsstrategie auf "volständig", danach hochladen und wenn's dann gut aussieht kann man die Erstellungsstrategie wieder zurücksetzen auf "differenziell" oder "inkremental".


Gruß,
Marjorie

Hilfe ist nicht selbstverständlich, deshalb halte ich ein "Dankeschön" nachdem jemandem geholfen wurde für überaus angebracht und höflich.

Viele hier im Forum veröffentlichte Scripts sind das geistige Eigentum der Ersteller und unterliegen somit das Copyright! Wenn ihr diese Scripts in eure persönliche Seite(n) oder auf Seiten für eure Kunden anwendet, ist ein Quellverweis auf den Beitrag mit dem Script nichts anderes als selbstverständlich.

#3

Bibserich

Forum-Sponsorin  (27 Punkte)  ·   weiblich  ·   Deutschland  ·    Nachricht senden
 https://www.philharmonischerchor-friedrichshafen.de

Vielen Dank für deine Antwort Marjorie, ich habe die Website heute schon 5x vollständig geladen und es hilft leider nicht. Gibt es noch eine andere Lösung? 
Der 1. Link nach "anzeigen" ist: https://www.bodensee-idylle.de/ 

Wenn ich auf andere Seiten gehe und wieder zurück auf Home, dann ist der Link: https://www.bodensee-idylle.de/index.html 

Liegt es daran? Danke für weitere Hilfe
Andrea 

#4

W2D Fan

Co-Admin  (3012 Punkte)  ·   weiblich  ·   Niederlande  ·    Nachricht senden
 http://www.w2dfan.nl

Wenn ich auf das Häuschen klicke um zu die Startseite zurück zu kehren lande ich wie gewünscht auf http://www.bodensee-idylle.de/index.html.

Für mich sieht es so aus als hast du sowohl eine SSL-verschlüßelte Webseite als eine unverschlüßelte Webseite auf der gleiche Domain. Das kann nur in die Hose gehen. Lösche mal via ein externes FTP-Programm wie zB  WinSCP oder Filezilla alles was auf deinem Webserver steht und erstelle dann noch mal die Seite und lade sie hoch auf einen jungfraulichen Server.


Gruß,
Marjorie

Hilfe ist nicht selbstverständlich, deshalb halte ich ein "Dankeschön" nachdem jemandem geholfen wurde für überaus angebracht und höflich.

Viele hier im Forum veröffentlichte Scripts sind das geistige Eigentum der Ersteller und unterliegen somit das Copyright! Wenn ihr diese Scripts in eure persönliche Seite(n) oder auf Seiten für eure Kunden anwendet, ist ein Quellverweis auf den Beitrag mit dem Script nichts anderes als selbstverständlich.

#5

Bibserich

Forum-Sponsorin  (27 Punkte)  ·   weiblich  ·   Deutschland  ·    Nachricht senden
 https://www.philharmonischerchor-friedrichshafen.de

Ja, danke, das werde ich probieren. Es soll ja auch eine verschlüsselte Website sein. Hoffentlich klappt es.
Gruß Andrea

#6

Bibserich

Forum-Sponsorin  (27 Punkte)  ·   weiblich  ·   Deutschland  ·    Nachricht senden
 https://www.philharmonischerchor-friedrichshafen.de

DONE 🙂
Vielen Dank, es funktioniert wieder. 

#7

deekay

Forum-Sponsor  (130 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://www.lippe-event.de

Eine schöne Seite hast du da gebaut. Aufgrund des Kontaktformulars musst du sie aber noch auf ssl umstellen.

#8

Bibserich

Forum-Sponsorin  (27 Punkte)  ·   weiblich  ·   Deutschland  ·    Nachricht senden
 https://www.philharmonischerchor-friedrichshafen.de

#9

W2D Fan

Co-Admin  (3012 Punkte)  ·   weiblich  ·   Niederlande  ·    Nachricht senden
 http://www.w2dfan.nl

Die Seite ist noch immer aufrufbar als http://www.bodensee-idylle.de. Vermutlich mußt du per .htaccess umleiten auf die SSL-verschlüßelte Seite. Ich kenne mich aber damit nicht aus und kann damit auch nicht weiterhelfen.


Gruß,
Marjorie

Hilfe ist nicht selbstverständlich, deshalb halte ich ein "Dankeschön" nachdem jemandem geholfen wurde für überaus angebracht und höflich.

Viele hier im Forum veröffentlichte Scripts sind das geistige Eigentum der Ersteller und unterliegen somit das Copyright! Wenn ihr diese Scripts in eure persönliche Seite(n) oder auf Seiten für eure Kunden anwendet, ist ein Quellverweis auf den Beitrag mit dem Script nichts anderes als selbstverständlich.

#10

Bibserich

Forum-Sponsorin  (27 Punkte)  ·   weiblich  ·   Deutschland  ·    Nachricht senden
 https://www.philharmonischerchor-friedrichshafen.de

Mist, ich kenne mich damit auch nicht aus. Bei den anderen Seiten die ich betreue, ist der Anbieter Strato (darf ich das hier schreiben?) und da gibt es die Funktion "Umleitung auf https erzwingen". Diese Seite wird bei One gehostet und da finde ich diese Funktion nicht. Wie mache ich diese Umleitung?

Gruß Andrea

#11

W2D Fan

Co-Admin  (3012 Punkte)  ·   weiblich  ·   Niederlande  ·    Nachricht senden
 http://www.w2dfan.nl

Wie ich schon sagte ich kenne mich damit  nicht aus. Soweit ich weiß mußt du dafür selbst eine .htaccess-Datei erstellen und in den Root der Webseite laden. Am besten fragst du Thomas über seine Kontakt & Support-Seite ob er dich dabei bzw damit helfen kann.


Gruß,
Marjorie

Hilfe ist nicht selbstverständlich, deshalb halte ich ein "Dankeschön" nachdem jemandem geholfen wurde für überaus angebracht und höflich.

Viele hier im Forum veröffentlichte Scripts sind das geistige Eigentum der Ersteller und unterliegen somit das Copyright! Wenn ihr diese Scripts in eure persönliche Seite(n) oder auf Seiten für eure Kunden anwendet, ist ein Quellverweis auf den Beitrag mit dem Script nichts anderes als selbstverständlich.

#12

Volker W.

Administrator  (6650 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   VolkerWarmers  ·   volkerw68

Für mich sieht es so aus als hast du sowohl eine SSL-verschlüßelte Webseite als eine unverschlüßelte Webseite auf der gleiche Domain. Das kann nur in die Hose gehen. Lösche mal via ein externes FTP-Programm wie zB  WinSCP oder Filezilla alles was auf deinem Webserver steht und erstelle dann noch mal die Seite und lade sie hoch auf einen jungfraulichen Server.

Der Lösungsvorschlag war/ist absolut korrekt, aber eine Problemursache "eine SSL-verschlüsselte Webseite als auch eine unverschlüsselte Webseite auf der gleichen Domain" gibt es in dieser Form nicht. Insofern keine https-Weiterleitung aktiv geschaltet ist, läuft eine Domain eben sowohl SSL-verschlüsselt als auch unverschlüsselt gleichzeitig, das ist völlig normal.

Die tatsächliche Ursache des Problems war ganz offensichtlich eine index.php der alten Website und die index.html der neuen Website parallel nebeneinander im Rootverzeichnis der Domain. Die index.php hat bei Aufruf des Rootverzeichnisses ohne gezielte Dateiangabe dann Vorrang und zeigt weiterhin den alten, dann jedoch un- bzw. falsch formatierten Inhalt an (da CSS-Dateien entweder nicht existent oder völlig unpassend).


@Bibserich:

https / SSL erzwingen solltest Du via .htaccess Datei (im Root der Domain):

<IfModule mod_rewrite.c>

	RewriteEngine On
	RewriteBase /

	RewriteCond %{SERVER_PORT} !=443 [OR]
	RewriteCond %{HTTP_HOST} !^(www\.bodensee-idylle\.de)?$ [NC]
	RewriteRule (.*) https://www.bodensee-idylle.de/$1 [R=301,L]

</IfModule>


Desweiteren solltest Du in den Veröffentlichungseinstellungen Deines Projekts unter HTTP Target-URL https://www.bodensee-idylle.de/ eintragen. Dann neu erstellen sowie veröffentlichen und gut ist.


Viele Grüße,
Volker

Volker W. Musik & Sounds  ·  Facebook  ·  Google+  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

Hilfe-Anfragen per PN, E-Mail usw. werden ab sofort nicht mehr beantwortet. Genau dafür ist dieses Forum da. Vielen Dank!

#13

Bibserich

Forum-Sponsorin  (27 Punkte)  ·   weiblich  ·   Deutschland  ·    Nachricht senden
 https://www.philharmonischerchor-friedrichshafen.de

Hallo Volker, 

vielen Dank, die Änderung in der Target-URL hatte ich schon gemacht. Deine Angaben für https / SSL erzwingen sind für mich leider böhmische Dörfer 😞 .
Wo finde ich diese Datei? 

Grüße, Andrea 

#14

Volker W.

Administrator  (6650 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   VolkerWarmers  ·   volkerw68

Nirgendwo!

Lege Sie auf Deinem Rechner als htaccess.txt mit dem Inhalt wie in Beitrag #12 gezeigt an, lade sie via FTP-Programm (z.B. WinSCP oder Filezilla) ins Rootverzeichnis Deiner Domain hoch und benenne sie dort in .htaccess (exakt so mit Punkt am Anfang!) um.


Viele Grüße,
Volker

Volker W. Musik & Sounds  ·  Facebook  ·  Google+  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

Hilfe-Anfragen per PN, E-Mail usw. werden ab sofort nicht mehr beantwortet. Genau dafür ist dieses Forum da. Vielen Dank!

#15

Bibserich

Forum-Sponsorin  (27 Punkte)  ·   weiblich  ·   Deutschland  ·    Nachricht senden
 https://www.philharmonischerchor-friedrichshafen.de

Vielen Dank Volker, es hat funktioniert, allerdings war die Seite zuerst nicht mehr erreichbar. Erst nachdem ich die umbenannte Datei wieder gelöscht habe, gings wieder. Die Website ist jetzt immer verschlüsselt. 
Danke und Grüße
Andrea

#16

Volker W.

Administrator  (6650 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   VolkerWarmers  ·   volkerw68

#17

Bibserich

Forum-Sponsorin  (27 Punkte)  ·   weiblich  ·   Deutschland  ·    Nachricht senden
 https://www.philharmonischerchor-friedrichshafen.de

hmmmmm.... bei mir aber schon. Und nun? 

#18

Volker W.

Administrator  (6650 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   VolkerWarmers  ·   volkerw68

#19

Bibserich

Forum-Sponsorin  (27 Punkte)  ·   weiblich  ·   Deutschland  ·    Nachricht senden
 https://www.philharmonischerchor-friedrichshafen.de

Unter Chrome: nach wie vor ja (warum auch immer) unter Edge: nein 
Ich habe alles so gemacht wie von dir beschrieben, die Textdatei erstellt, hochgeladen und umbenannt. Danach ging nichts mehr. Das Rootverzeichnis ist das allererste, die oberste Ebene, ja? 
Sorry für meine "dummen" Fragen, ich komme bestens zurecht mit dem Programm und habe schon einiges gelernt, aber da komme ich gerade an meine Grenzen.
Grüße, Andrea 

#20

Volker W.

Administrator  (6650 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   VolkerWarmers  ·   volkerw68

Ich sprach nicht vom FTP-Rootverzeichnis, sondern vom Rootverzeichnis Deiner Domain, sprich von genau demjenigen Verzeichnis welches als FTP Remote-Folder in Deinem Siquando-Projekt eingetragen ist. Exakt da gehört die in Beitrag #12 genannte .htaccess Datei hinein.

Berücksichtige bei Tests mit (möglichst verschiedenen) Browsern auch immer deren Cache. Lösche diesen, bevor Du ganz frische Änderungen prüfst. Ansonsten werden Dir veraltete Seiten weiterhin angezeigt oder im Falle von Änderungen an der .htaccess falsche Verhaltensweisen vorgegaukelt.


Viele Grüße,
Volker

Volker W. Musik & Sounds  ·  Facebook  ·  Google+  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

Hilfe-Anfragen per PN, E-Mail usw. werden ab sofort nicht mehr beantwortet. Genau dafür ist dieses Forum da. Vielen Dank!

#21

Bibserich

Forum-Sponsorin  (27 Punkte)  ·   weiblich  ·   Deutschland  ·    Nachricht senden
 https://www.philharmonischerchor-friedrichshafen.de

Ich bin wirklich dankbar für deine Hilfe und Mühe und schäme mich schon ein bisschen, aber da bin ich überfordert und weiß nicht, wo ich das finde. 😢

Gruß, Andrea

#22

Thomas

Co-Admin  (1870 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://siquando-designs.de

Es gibt keinen Grund sich zu schämen. Bei deinem Hoster musstest du sicherlich irgendwo angeben in welchem Ordner die Seite www.bodensee-idylle.de liegt. Genau in diesem Ordner gehört die Datei, siehe auch in Project Central -> Projekt-Einstellungen -> Webserver -> Basisordner.


Viele Grüße
Thomas

siquando-designs.de (ganz NEU: Santa Cruz Pro für Pro Web 3 und Apollon 10 für Siquando Shop, Tutorials, Templateübersichten & Support für Shop 10 + Pro Web 3)

#23

Volker W.

Administrator  (6650 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   VolkerWarmers  ·   volkerw68

..., siehe auch in Project Central -> Projekt-Einstellungen -> Webserver -> Basisordner.

Nö, Thomas. Da wir hier bei Siquando Web 10 (und nicht bei Pro Web) sind, muß im Programm bzw. Projekt bei Datei -> Website- und FTP-Eigenschaften... -> Veröffentlichen -> FTP Remote-Folder geschaut werden. 😉


Viele Grüße,
Volker

Volker W. Musik & Sounds  ·  Facebook  ·  Google+  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

Hilfe-Anfragen per PN, E-Mail usw. werden ab sofort nicht mehr beantwortet. Genau dafür ist dieses Forum da. Vielen Dank!

#24

Bibserich

Forum-Sponsorin  (27 Punkte)  ·   weiblich  ·   Deutschland  ·    Nachricht senden
 https://www.philharmonischerchor-friedrichshafen.de

#25

Volker W.

Administrator  (6650 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   VolkerWarmers  ·   volkerw68

Die Angelegenheit hat mit "via SSH hochladen" nichts zu tun.

Wenn bei FTP Remote-Folder nichts steht, bedeutet dies, daß FTP-Rootverzeichnis und Domain-Rootverzeichnis identisch sind. Erstelle also die htaccess.txt gemäß Beitrag #12, lade sie via FTP-Programm in das FTP-/Domain-Rootverzeichnis hoch und benenne sie dort dann in .htaccess um.

Danach sollte die Weiterleitung direkt funktionieren. Falls dies wider Erwarten nicht so sein sollte, solltest Du Dich diesbezüglich am besten direkt an Deinen Provider One wenden.

Teile aber auf jeden Fall nochmal einen möglichst genauen Status mit (Ist-Zustand inkl. Screenshots Deiner .htaccess mit aktuellem Inhalt, wo diese auf dem Server genau liegt usw.).


Viele Grüße,
Volker

Volker W. Musik & Sounds  ·  Facebook  ·  Google+  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

Hilfe-Anfragen per PN, E-Mail usw. werden ab sofort nicht mehr beantwortet. Genau dafür ist dieses Forum da. Vielen Dank!

#26

Bibserich

Forum-Sponsorin  (27 Punkte)  ·   weiblich  ·   Deutschland  ·    Nachricht senden
 https://www.philharmonischerchor-friedrichshafen.de

Rückmeldung: Es funktioniert jetzt, habe aber von One einen anderen Code bekommen. 
Danke für die Hilfe
Grüße Andrea

#27

Volker W.

Administrator  (6650 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   VolkerWarmers  ·   volkerw68

Vielen Dank für Deine Rückmeldung, welche dem Forum und anderen Mitgliedern mit einem ähnlichen Problem aber in dieser Form rein gar nichts bringt.

Welchen Code genau hast Du von One erhalten? Bitte poste diesen hier mal zur Info. Benutze dafür bitte die { ; } Schaltfläche im Editor.

Danke Dir!


Anmerkung:

Der von mir bereitgestellte Code funktioniert bei bisher jedem mir bekannten Provider, der individuelle .htaccess Dateien seiner Hosting-Kunden unterstützt.


Viele Grüße,
Volker

Volker W. Musik & Sounds  ·  Facebook  ·  Google+  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

Hilfe-Anfragen per PN, E-Mail usw. werden ab sofort nicht mehr beantwortet. Genau dafür ist dieses Forum da. Vielen Dank!

#28

Bibserich

Forum-Sponsorin  (27 Punkte)  ·   weiblich  ·   Deutschland  ·    Nachricht senden
 https://www.philharmonischerchor-friedrichshafen.de

Sorry, hier ist der Code:

Grüße, Andrea

#Rewrite everything to https 
RewriteEngine On 
RewriteCond %{HTTPS} !=on 
RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
#29

Volker W.

Administrator  (6650 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   VolkerWarmers  ·   volkerw68

#30

Bibserich

Forum-Sponsorin  (27 Punkte)  ·   weiblich  ·   Deutschland  ·    Nachricht senden
 https://www.philharmonischerchor-friedrichshafen.de

und warum muss es das? Wichtig ist doch verschlüsselt, ?!? Ich habe auch bei der Google Search Console die Anzeige ohne www festgelegt. 
Bitte erkläre mir den Unterschied und was es bewirkt. 
Grüße, Andrea

2098 Aufrufe | 33 Beiträge