Willkommen, Gast!   de
    w2d · Siquando – Forum  
Die Kompetenz-Community
für web to date, shop to date, NG und
Siquando Web / Shop / Pro
Sonntag, 20. August 2017, 02:22

Facebook

Spende ans Forum

Wer ist online?

Klappen
Gäste: 25

Seite bookmarken

Facebook
Twitter
Google
LinkedIn

Powered by All-Inkl.com

Forum - eigene Fehlerseite

Offline ruhrbruch Männlich
Eroberer
0123
63 Punkte
Homepage Persönliche Nachricht senden
eigene Fehlerseite
# 1 Zum Seitenanfang

Hallo zusammen,

auch wenn das Thema schon oft aufgegriffen wurde, komme ich nicht zur Lösung. Ich habe mich komplett an die Abfolgen zur Erstellung einer eigenen Fehlerseite gehalten, kann diese auch aufrufen, allerdings wird nicht auf die Fehlerseite umgeleitet. Ich hatte zunächst im Verdacht, dass es an dem Weglassen des content liegt, aber auch, wenn ich im Ordner content die htacess-Datei verändere, passiert nichts.

Hier die Fehlerseite:

http://www.goetheschule-essen.de/404error.php

 

Hat jemand von Euch Profis eine Idee?

LG

Jan

Bild 03.09.2015, 17:16
Offline harlekin8 Männlich
Experte
01
307 Punkte
Homepage Persönliche Nachricht senden
RE:eigene Fehlerseite
# 2 Zum Seitenanfang

Hallo Jan,

natürlich kannst du auch externe Scripts benutzen, aber warum so umständlich ?! Manche Provider bieten die Umleitung auf eigene Error-Pages an - so auch Strato wo deiner Seite auch gehostet ist ... ;-)

Strato Error Pages >>

Schöne Woche !

---

≡ JORDAN RALLY RAID ••• ≡  Wordpress Responsiv    ≡ MEDIATION FREIBURG ••• ≡ Wordpress Responsiv

... falls Ihr euch erkenntlich zeigen möchtet ... mein

 

amazon Wunschzettel >>
Ingo Gerhardt
818724189
Packstation 127
D-79114 Freiburg i. Br.

Bild 03.09.2015, 17:48
Offline Volker W. Männlich
Administrator
Forum-Betreiber
012345
5814 Punkte
Homepage Persönliche Nachricht senden
RE:eigene Fehlerseite
# 3 Zum Seitenanfang

@Jan:

Woher sollen wir nun wissen, was Du genau gemacht hast? ;-)


Versuche mal folgende .htaccess im Root Deiner Pro Web Präsenz:

AddDefaultCharset UTF-8
DirectoryIndex index.php index.htm index.html
Options +FollowSymLinks -Indexes
 
ErrorDocument 400 /400error.php
ErrorDocument 401 /401error.php
ErrorDocument 403 /403error.php
ErrorDocument 404 /404error.php
ErrorDocument 500 /500error.php
 
<IfModule mod_rewrite.c>
 
	RewriteEngine On
 
	RewriteRule ^sitemap\.xml$ /sitemap.xml.php [L]
	RewriteRule ^robots\.txt$ /robots.txt.php [L]
 
	RewriteCond %{THE_REQUEST} ^[A-Z]{3,9}\ /sitemap\.[^.]+\.php\ HTTP/ [NC]
	RewriteRule ^sitemap\.[^.]+\.php$ http://www.goetheschule-essen.de/sitemap.xml [R=301,L]
 
	RewriteCond %{THE_REQUEST} ^[A-Z]{3,9}\ /robots\.[^.]+\.php\ HTTP/ [NC]
	RewriteRule ^robots\.[^.]+\.php$ http://www.goetheschule-essen.de/robots.txt [R=301,L]
 
	RewriteCond %{REQUEST_FILENAME} !-f
	RewriteCond %{REQUEST_FILENAME}/index.html !-f
	RewriteCond %{REQUEST_FILENAME}/index.php !-f
	RewriteRule ^(.*)$ /index.php?ngq=/$1 [QSA,L]
 
	RewriteCond %{HTTP_HOST} !^(www\.goetheschule-essen\.de)?$ [NC]
	RewriteRule (.*) http://www.goetheschule-essen.de/$1 [R=301,L]
 
</IfModule>

Paß Dir dies ggf. noch wunschgemäß an. Und vergiß nicht die weiteren Änderungen aus Thomas' Anleitung.


Anmerkung: Von mir ungetestet!!! Sollte aber normalerweise gehen.


Viel Erfolg!

---

Viele Grüße,
Volker

Volker W. Musik & Sounds  ·  Facebook  ·  Twitter  ·  Google+  ·  StayFriends  ·  LinkedIn  ·  XING

Hilfe-Anfragen per PN, E-Mail usw. werden ab sofort nicht mehr beantwortet. Genau dafür ist dieses Forum da. Vielen Dank!

Bild 03.09.2015, 17:59
Offline Volker W. Männlich
Administrator
Forum-Betreiber
012345
5814 Punkte
Homepage Persönliche Nachricht senden
RE:eigene Fehlerseite
# 4 Zum Seitenanfang

Nachtrag:

Die Dateien xxxerror.php (z.B. 404error.php) hast Du im Root Deiner Pro Web Präsenz auch via FTP mit entsprechend sinnvollem Inhalt angelegt???

Gemäß dem von Dir angegebenen Link http://www.goetheschule-essen.de/404error.php wohl eher nicht ... ;-)

---

Viele Grüße,
Volker

Volker W. Musik & Sounds  ·  Facebook  ·  Twitter  ·  Google+  ·  StayFriends  ·  LinkedIn  ·  XING

Hilfe-Anfragen per PN, E-Mail usw. werden ab sofort nicht mehr beantwortet. Genau dafür ist dieses Forum da. Vielen Dank!

Bild 03.09.2015, 18:12
Offline Volker W. Männlich
Administrator
Forum-Betreiber
012345
5814 Punkte
Homepage Persönliche Nachricht senden
RE:eigene Fehlerseite
# 5 Zum Seitenanfang

Noch ein Nachtrag:

Außer der Startseite wird aktuell keine einzige Seite Deiner Präsenz mehr angezeigt. Alle Links sind tot (404). Vermutlich hast Du beim Einbau von Thomas' Anleitung einen dicken Bock geschossen.


Da mußt Du in Deinem eigenen Interesse wohl umgehend nochmal ran (oder rangehen lassen).

---

Viele Grüße,
Volker

Volker W. Musik & Sounds  ·  Facebook  ·  Twitter  ·  Google+  ·  StayFriends  ·  LinkedIn  ·  XING

Hilfe-Anfragen per PN, E-Mail usw. werden ab sofort nicht mehr beantwortet. Genau dafür ist dieses Forum da. Vielen Dank!

Bild 03.09.2015, 18:26
Offline ruhrbruch Männlich
Eroberer
0123
63 Punkte
Homepage Persönliche Nachricht senden
RE:eigene Fehlerseite
# 6 Zum Seitenanfang

Ich hatte Ingos Tipp über Strato versucht, dabei hat Strato die htacess überschrieben. Problem wieder gelöst und mit Deinem Code versucht - leider ohne Erfolg, obwoh ldie Datei im root liegt.

 

Gruß

Jan

Bild 03.09.2015, 19:03
Offline Volker W. Männlich
Administrator
Forum-Betreiber
012345
5814 Punkte
Homepage Persönliche Nachricht senden
RE:eigene Fehlerseite
# 7 Zum Seitenanfang

Du hast garantiert Thomas' Anleitung nicht 100% korrekt befolgt. Und eine Errorseite http://www.goetheschule-essen.de/404error.php existiert offensichtlich immer noch nicht.


Tipp:

Laß Dir das besser von einem Experten machen.

---

Viele Grüße,
Volker

Volker W. Musik & Sounds  ·  Facebook  ·  Twitter  ·  Google+  ·  StayFriends  ·  LinkedIn  ·  XING

Hilfe-Anfragen per PN, E-Mail usw. werden ab sofort nicht mehr beantwortet. Genau dafür ist dieses Forum da. Vielen Dank!

Bild 03.09.2015, 19:04
Offline harlekin8 Männlich
Experte
01
307 Punkte
Homepage Persönliche Nachricht senden
RE:eigene Fehlerseite
# 8 Zum Seitenanfang

"dabei hat Strato die htacess überschrieben"

... das ist so nicht richtig Jan, wie du unten entnehmen kannst. In der Hilfe steht (die du offensichtlich nicht gänzlich gelesen hast), wie du vorgehen musst:
In der Hilfe steht ganz unten:

Beachten Sie bitte, das der Website Configurator eine neue .htaccess Datei auf Ihrem Webspeicherplatz hinterlegt. Für gegebenenfalls bereits vorhandene, selbst erstellte .htaccess Dateien wird automatisch ein Backup für Sie angelegt. Das Backup erkennen Sie an der Namensgebung .htaccess.bak., die Inhalte dieser .htaccess.bak Datei werden nicht mehr berücksichtigt. Daher ist es gegebenenfalls notwendig, dass Sie diese manuell in Ihre neue .htaccess Datei wieder einpflegen.

Heißt du musst nur deine .htaccess.bak öffnen und die fehlenden Inhalte in der neuen .htaccess ergänzen ...

Bye

 

---

≡ JORDAN RALLY RAID ••• ≡  Wordpress Responsiv    ≡ MEDIATION FREIBURG ••• ≡ Wordpress Responsiv

... falls Ihr euch erkenntlich zeigen möchtet ... mein

 

amazon Wunschzettel >>
Ingo Gerhardt
818724189
Packstation 127
D-79114 Freiburg i. Br.

Dieser Beitrag wurde bereits 1 mal bearbeitet, zuletzt von »harlekin8« (03.09.2015, 19:26)

Bild 03.09.2015, 19:24
Offline ruhrbruch Männlich
Eroberer
0123
63 Punkte
Homepage Persönliche Nachricht senden
RE:eigene Fehlerseite
# 9 Zum Seitenanfang

So, ich habe das so gemacht, leider ohne Erfolg. Volker, die Datei heißt bei mir fehler.php, ich habe die Dateien entsprechend geändert. Das hat früher bei W2Date immer geklappt... ich bin ratlos (:

Gruß

Bild 03.09.2015, 20:02
Offline ruhrbruch Männlich
Eroberer
0123
63 Punkte
Homepage Persönliche Nachricht senden
RE:eigene Fehlerseite
Zitat von: ruhrbruch

So, ich habe das so gemacht, leider ohne Erfolg. Volker, die Datei heißt bei mir fehler.php, ich habe die Dateien entsprechend geändert. Das hat früher bei W2Date immer geklappt... ich bin ratlos (:

Meine Datei :

#######################################################################
#     Diese .htaccess wurde vom STRATO-Webservermanager erstellt      #
#######################################################################


ErrorDocument 401 http://www.goetheschule-essen.de/fehler.php
ErrorDocument 403 http://www.goetheschule-essen.de/fehler.php
ErrorDocument 404 http://www.goetheschule-essen.de/fehler.php
ErrorDocument 500 http://www.goetheschule-essen.de/fehler.php

Options -Indexes

AddType application/x-httpd-php5 .php .php3 .php4 .php5


RewriteEngine On
RewriteRule ^sitemap\.xml$ /sitemap.xml.php [L]
RewriteRule ^robots\.txt$ /robots.txt.php [L]
 
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME}/index.html !-f
RewriteCond %{REQUEST_FILENAME}/index.php !-f
RewriteRule ^(.*)$ /index.php?ngq=/$1 [QSA,L]

Gruß

 

Bild 03.09.2015, 20:20
Offline Volker W. Männlich
Administrator
Forum-Betreiber
012345
5814 Punkte
Homepage Persönliche Nachricht senden
RE:eigene Fehlerseite

Pro Web (MySQL basiert, Links via mod_rewrite)  ist nicht web to date (normale Dateistruktur auf Webserver). Also laufen hier die Sachen etwas anders.

Mache am besten einmal alle .htaccess Änderungen rückgängig, am besten über Project Central -> Administrative Aufgaben -> Installieren oder Aktualisieren -> "Neuinstallation der Komponenten erzwingen" aktivieren -> OK.

Danach machst Du Dir Sicherungen aller zu modifizierenden Dateien, fängst mit der Modifikation "Fehlerseite" an, prüfst diese auf korrekte Funktionsfähigkeit und startest danach einen neuen Versuch mit Thomas' Anleitung zur Entfernung des /content. Insofern Du alle Änderungen sauber und sorgfältig vornimmst, klappt das auch.

Ansonsten beherzige meinen Tipp, dies von einem Experten machen zu lassen.

---

Viele Grüße,
Volker

Volker W. Musik & Sounds  ·  Facebook  ·  Twitter  ·  Google+  ·  StayFriends  ·  LinkedIn  ·  XING

Hilfe-Anfragen per PN, E-Mail usw. werden ab sofort nicht mehr beantwortet. Genau dafür ist dieses Forum da. Vielen Dank!

Bild 03.09.2015, 22:21
Offline harlekin8 Männlich
Experte
01
307 Punkte
Homepage Persönliche Nachricht senden
RE:eigene Fehlerseite

,,, keine Ahnung warum es bei dir nicht geht ... Bin auch bei Strato und habe es soeben getestet.

Funktioniert einwandfrei ...

Die Testseite:

http://siqpro.harlekin8.de

Dir URL für die Fehlerseite ist ursprünglich:

http://siqpro.harlekin8.de/common/info/errorseite.html

Für die Fehlerseite habe ich einfach eine Infoseite angelegt ...
Danach wie von Strato angegeben die Umleitung eingerichtet. (Datei --> /common/info/errorseite.html) und gespeichert.

Die neue .htaccess habe ich mit den alten Eintragungen ergänzt.

Beispiel Errorseite:

http://siqpro.harlekin8.de/irgendwas


Aufwand mit Errorseiteerstellung 10 min ...


Bye !

---

≡ JORDAN RALLY RAID ••• ≡  Wordpress Responsiv    ≡ MEDIATION FREIBURG ••• ≡ Wordpress Responsiv

... falls Ihr euch erkenntlich zeigen möchtet ... mein

 

amazon Wunschzettel >>
Ingo Gerhardt
818724189
Packstation 127
D-79114 Freiburg i. Br.

Dieser Beitrag wurde bereits 1 mal bearbeitet, zuletzt von »harlekin8« (03.09.2015, 23:20)

Bild 03.09.2015, 23:07
Offline WoRa Männlich
Neuling
0
8 Punkte
Homepage Persönliche Nachricht senden
RE:eigene Fehlerseite

Hallo Forum,

nun komme auch ich noch einmal mit einem Problem zur eigenen Fehlerseite. Die Seite http://www.zieler.de/error404.php existiert (wenn auch noch nicht hübsch...) und lässt sich im Browser aufrufen. Die .htaccess sieht so aus:

AddDefaultCharset UTF-8
DirectoryIndex index.php index.htm index.html
Options +FollowSymLinks -Indexes
 
ErrorDocument 400 /error404.php
ErrorDocument 401 /error404.php
ErrorDocument 403 /error404.php
ErrorDocument 404 /error404.php
ErrorDocument 500 /error404.php
 
<IfModule mod_rewrite.c>

RewriteEngine On
RewriteBase /

RewriteRule ^sitemap\.xml$ /sitemap.xml.php [L]
RewriteRule ^robots\.txt$ /robots.txt.php [L]

RewriteCond %{THE_REQUEST} ^[A-Z]{3,9}\ /sitemap\.[^.]+\.php\ HTTP/ [NC]
RewriteRule ^sitemap\.[^.]+\.php$ http://www.zieler.de/sitemap.xml [R=301,L]
 
RewriteCond %{THE_REQUEST} ^[A-Z]{3,9}\ /robots\.[^.]+\.php\ HTTP/ [NC]
RewriteRule ^robots\.[^.]+\.php$ http://www.zieler.de/robots.txt [R=301,L]


RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME}/index.html !-f
RewriteCond %{REQUEST_FILENAME}/index.php !-f
RewriteRule ^(.*)$ /index.php?ngq=/$1 [QSA,L]

RewriteCond %{HTTP_HOST} !^(www\.zieler\.de)?$ [NC]
RewriteRule (.*) http://www.zieler.de/$1 [R=301,L]
 
</IfModule>

Allerdings wird die Seite bei falschen URLs nicht aufgerufen. Kann mir jemand sagen, wo der Fehler liegt?

Vielen Dank und viele Grüße

Wolfgang

Bild 10.01.2017, 18:03
Offline Thomas Männlich
Co-Admin
012345
1424 Punkte
Homepage Persönliche Nachricht senden
RE:eigene Fehlerseite

Bevor die .htaccess überhaupt greift und die „ErrorDocuments“ aus ihr anzeigt, wird bereits durch Pro Web selber ein 404-header gesetzt, so dass man einfach eine weiße sieht.

Vor einiger Zeit habe ich die Angabe per MetaTag für einen Kunden realisiert.

 404 Fehlerseite angeben

---

Viele Grüße
Thomas

siquando-designs.de (responsives Shop und Web 9 Template mit „vertika”lem Menü, Tutorials, Templateübersichten & Support für Shop 9 + Pro Web)

Bild 11.01.2017, 16:10
Offline Volker W. Männlich
Administrator
Forum-Betreiber
012345
5814 Punkte
Homepage Persönliche Nachricht senden
RE:eigene Fehlerseite

@Thomas:

Hat Siquando dies irgendwann nachträglich implementiert?

Meine Fehlerseite https://www.warmers.de/error/ wird nämlich auch nicht mehr aufgerufen, wenn eine ungültige URL eingegeben wird. Und ich bin mir völlig sicher, daß dies früher mal so war. Ich prüfe Dinge, die ich bei mir implementiere, ja grundsätzlich auch auf korrekte Funktionalität.

Sonst hätte ich die Fehlerseite definitiv auch nicht final eingebaut (dies übrigens genau in der in Beitrag #3 angegebenen Art und Weise) ......

---

Viele Grüße,
Volker

Volker W. Musik & Sounds  ·  Facebook  ·  Twitter  ·  Google+  ·  StayFriends  ·  LinkedIn  ·  XING

Hilfe-Anfragen per PN, E-Mail usw. werden ab sofort nicht mehr beantwortet. Genau dafür ist dieses Forum da. Vielen Dank!

Bild 11.01.2017, 18:23
Offline WoRa Männlich
Neuling
0
8 Punkte
Homepage Persönliche Nachricht senden
RE:eigene Fehlerseite

Das Helpdesk von Siquando hat mit dazu heute Folgendes geschrieben:

"Wir haben uns Ihren Fall noch einmal genauer angesehen.
Apache muss die entsprechenden Error-Documents bei internen (selbst ausgelösten) und externen (durch Module oder (F)CGI-Applikationen) 404-Fehlern ausliefern. Ansonsten funktioniert eine Umleitung der Seite 404 nicht korrekt
Folgenden Workaround können wir Ihnen anbieten:
Sie finden in Ihrer Pro Web Installation unter "classes/util/" die Datei ngutil.php finden.
Ab Zeile 480 finden Sie die Funktion "HeaderNotFound()". Hier können Sie ein beliebiges Verhalten definieren z.B. auch eine 301 Header Weiterleitung für 404 Fehler.
Anbei erhalten Sie die angepasste Datei. Diese verweist auf die Seite /common/404.html" die Sie noch erstellen müssen. Dazu müssen Sie im Ordner "Allgemeine Seiten" eine Seite anlegen, die Sie 404 nennen müssen."

Die Funktion in der von Siquando angepassten Datei sieht so aus:

}
  
    public static function HeaderNotFound() {
        header("HTTP/1.1 301 Moved Permanently");
        header('Location: /common/404.html');
        //die ();


Wobei mir nicht klar ist, warum hier 301 steht, ich habe daraus "404 Not found" gemacht. Es funktioniert.


LG

Wolfgang

Bild 11.01.2017, 20:48
Offline Thomas Männlich
Co-Admin
012345
1424 Punkte
Homepage Persönliche Nachricht senden
RE:eigene Fehlerseite

Ein nicht gefundenes Dokument mit einem 301 Header zu kennzeichnen, ist ja fast schon boshaft. Stell dir vor du willst in eine fremde Stadt und fragst einen Passanten nach einer Straße die es nicht gibt. Der Passant weiß von der nicht existierenden Straße, und statt dir zu sagen, dass es diese Straße nicht gibt, schickt er dich erstmal eine halbe Stunde durch die Stadt. Der Siquando Suppot empfiehlt dir genau das Gleiche wie dieser Passant.

Auch per header Location weiterzuleiten halte ich für Unsinn, denn ...common/404.html gibt als Status nicht 404 zurück.

Searchmetrics bspw. wertet den nicht vorhandenen Statuscode 404 als Fehler, und das berechtigt.

@Volker: Seit der ersten Version von Siquando Pro Web ist das so.

 

---

Viele Grüße
Thomas

siquando-designs.de (responsives Shop und Web 9 Template mit „vertika”lem Menü, Tutorials, Templateübersichten & Support für Shop 9 + Pro Web)

Dieser Beitrag wurde bereits 1 mal bearbeitet, zuletzt von »Thomas« (12.01.2017, 08:32)

Bild 12.01.2017, 08:25
Offline Volker W. Männlich
Administrator
Forum-Betreiber
012345
5814 Punkte
Homepage Persönliche Nachricht senden
RE:eigene Fehlerseite

Dann muß die Ursache, daß die Fehlerseite bei einer falsch eingegebenen / ungültigen URL nicht mehr aufgerufen wird, woanders liegen, denn das hat früher definitiv mal funktioniert.

Die Änderungen bei meiner Präsenz im vergangenen gut einem Jahr waren (u.a.):

  1. Entfernung des /content aus der URL
  2. Wechsel der PHP-Versionen von PHP 5.5 über PHP 5.6 auf aktuell PHP 7.0.14
  3. Wechsel des Designs auf Skew


Da ich Punkt 2 und 3 als Ursachen prinzipiell quasi ausschließe:

Kann es an Punkt 1 liegen?

---

Viele Grüße,
Volker

Volker W. Musik & Sounds  ·  Facebook  ·  Twitter  ·  Google+  ·  StayFriends  ·  LinkedIn  ·  XING

Hilfe-Anfragen per PN, E-Mail usw. werden ab sofort nicht mehr beantwortet. Genau dafür ist dieses Forum da. Vielen Dank!

Bild 12.01.2017, 21:19
Offline Thomas Männlich
Co-Admin
012345
1424 Punkte
Homepage Persönliche Nachricht senden
RE:eigene Fehlerseite

Hmm, schwer zu sagen, außer dass es nicht am Design liegt.

Vielleicht hat die Funktion „HeaderNotFound()“ nur innerhalb von domain.de/content/... Wirkung (gehabt) und du hast fleißig mit domain.de/... getestet.

---

Viele Grüße
Thomas

siquando-designs.de (responsives Shop und Web 9 Template mit „vertika”lem Menü, Tutorials, Templateübersichten & Support für Shop 9 + Pro Web)

Bild 13.01.2017, 08:21
Offline Volker W. Männlich
Administrator
Forum-Betreiber
012345
5814 Punkte
Homepage Persönliche Nachricht senden
RE:eigene Fehlerseite

Ich denke, eher genau andersherum. Oder?

Ich meine, als meine Website früher noch mit /content in der URL lief, klappte es mit der eigenen Fehlerseite via .htaccess (wenn ich mich jetzt nicht völlig vertue). Und seitdem ich /content entfernt habe, wohl nicht mehr.

Oder es gibt noch einen anderen uns bisher nicht bekannten Grund, daß die Fehlerseite bei der Eingabe ungültiger URLs nun nicht mehr aufgerufen wird.


Aber egal... - es gibt wichtigeres. Ich werde mir die Angelegenheit in der /classes/util/ngutil.php die Tage auch mal anschauen.

---

Viele Grüße,
Volker

Volker W. Musik & Sounds  ·  Facebook  ·  Twitter  ·  Google+  ·  StayFriends  ·  LinkedIn  ·  XING

Hilfe-Anfragen per PN, E-Mail usw. werden ab sofort nicht mehr beantwortet. Genau dafür ist dieses Forum da. Vielen Dank!

Bild 16.01.2017, 22:07
Bewertung: